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How can I easily perform management operations in AD from a customized Taskpad?
How can I create customized scripts to add even more features to a customized Taskpad?
Proactively alert on Active Directory replication performance with SolarWinds Server & Application Monitor (SAM). Active Directory replication issues can be tricky because there are so many potential root causes such as:

· Authentication problems

· Network Issues

· DNS Problems

· Replication queues too large

· Slow database queries

As your AD infrastructure grows, and the number of objects within it constantly changes, you might find that managing the growing number of users, groups and computers is becoming more than a headache. Fortunately for us, one of Active Directory's best features is the ability to delegate administrative control over specific objects to lower-level administrators.

You can read more about the administrative tasks delegation in an article that will be published shortly.

In this article I'll show how to create a custom tool (called Taskpad) from the Active Directory Users and Computers snap-in, and how to use this custom tool to ease some of your daily user management tasks.

Let's assume that your organization has an AD domain with several thousands of users. This domain consists of several distinctive divisions or departments. You have already created the right OU (Organization Unit) structure, and have already placed the right users accounts, groups and computers in their respective OUs.

We will also assume that one user named David will be responsible for managing all the user objects within the Sales OU. Other users might be responsible for other management tasks (such as adding computer objects, controlling Group Policy Objects or managing group membership, but for now let us concentrate on David).










This is how your AD domain structure looks like:
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Note: This is only an example, you should use your own OU structure, based upon management and GPO functionality considerations.

To create a custom MMC Taskpad for AD Users management

1. Click Start > Run, type MMC and click Enter.

2. In the new MMC window, click File > Add/Remove Snap-in.
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In the Add/Remove Snap-in window click on Add.
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In the Add Standalone Snap-in window, click on Active Directory Users and Computers and then click on the Add button.
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Back in the MMC window, click to expand the AD domain, and browse the required OU (in this case Corp > Sales). Right-click on the OU and select New Taskpad view.
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In the Welcome screen click Next.
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In the New Taskpad wizard page customize the view you want to retain. You can select a various sizes for the display, and other options related to the button captions and so on. When done, click Next.
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In the Taskpad Target window leave the default setting and click Next.
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In the Name and Description window type any name and description you want to appear in the Taskpad view. Click Next.
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In the Completing wizard page make sure that the Start New Task Wizard checkbox is selected and click Next.
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In the Command Type window leave the Menu Command selection and click Next.
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In the Shortcut Menu Command window notice how each right-click action associated with a user object is available for selection in the right-hand side window. Note that you do NOT need to select a specific user account on the left-hand side window, but in order for the right-click option to be available, you do need to select any one of the available user accounts. I usually build one or two fake user accounts just for this purpose, and when I'm done with the Taskpad creation, I delete those accounts.

In this step I've chosen the Properties task, but you can choose your own tasks.
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Note that although all right-click tasks are available for you to choose from, creating a task in this stage will not give the user that's supposed o use this Taskpad any additional permissions on the objects. I.e. if I choose New > Group from the available tasks and the user that's going to use this tool does NOT have the permission to create a new group in the Sales OU, he or she will NOT see the task button, although I've specifically added it to the task buttons.

When done click Next.

1. In the Name and Description window type or modify the needed info and click Next.
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In the Task Icon window browse to find the most appropriate icon (or add your own) and click Next.
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In the Completing the task wizard page select the Run this wizard again checkbox and click Finish.
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You will now have the option to re-run the wizard. Follow steps 10-12 and select the next task to add to the Taskpad.

This time I chose Delete.
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Follow steps 13 to 14 and re-run the wizard.

Here are some of the options available:

New User:
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Reset Password:
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Disable Account:
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In order to add the Enable Account option we will first need to manually disable one of the available user accounts, then the Enable Account option will be available to choose:

Enable Account:
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For other options, such as Find and Refresh, we will first need to configure the Command Source as Tree Item Task. Then the Find and Refresh options will become available.

Find:
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Refresh:
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You can also follow the same steps as before, but this time choose Shell Command in the Command Type window.
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Here you can add any command or batch file you want. For example, here is a command that will cause a Ping window to appear, pinging your DC:
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You can also add a Command Prompt window:
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And a command that will cause your DC to replicate with other DCs (this can be easily accomplished by using the REPADMIN command in a batch file).
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When finished adding all the required tasks and buttons, click Finish and look at what we've done:
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Notice how the original tree display is still visible. We will fix this right away.

1. Click on the View menu, then select Customize.
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In the Customize View window clear all checkboxes. Click Ok. Notice how all menus and the tree display have vanished.
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Now, we need to customize the tool's icon and settings before we save it. On the File menu click Options.
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In the Options menu give the Taskpad a good descriptive name and change the icon if you want. Also, in the Console Mode list, select User Mode - Limited Access, Single Window. Next, select the Do Not Save Changes checkbox, and clear the Allow the User to Customize Views checkbox. Click Ok.
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Next, save the Taskpad to anywhere you want. You can also send the Taskpad (which in fact is an .MSC file) by mail to the user responsible for the management of the OU. However remember that this user must also have the AD Users & Computers snap-in installed on his or her computer. See Extract Specific Tools from Adminpak.msi for more info.
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Now let us test the Taskpad:

1. Click on the saved Taskpad and run it.

[image: image34.png]" 1= =]

7
|3

£ mrertes

Ll
g
i
H
£

‘Custom toolsfor Seles OU management Name [Tvpe | Desciption )
tasks € Aextankn  User
@ Repleate 20 € Serberaore.. User
B Commend rompt Goobraly ser
€] Claire O'Domell User
B, Test Comectity @ DavidCohen  User
User
User
G s Gomsmtn User
@ Reset pessuond g JonGrande  User
KelyBue  User
@ Diable Accopnt. € Vi ke Uier

X pekete -
" Comput

User


















You will notice how the list of users is found on the right, and the list of available tasks is on the left. See how the available tasks and buttons change as you click on various objects. For example, when you click on a disabled user account, the Enable button will appear:
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and when you click on User, a new user dialog box appears:
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In conclusion, the Taskpad views are powerful add-ons to the administrator's arsenal, and can be used in various scenarios. Remember that the Taskpad view is not just limited to the AD Users & Computers snap-in, but can be used in virtually and available snap-in. Also, as a security measure, do NOT rely on the Taskpad's available buttons to prevent a user from doing harm. Use good permission strategy to protect your resources, and only use the Taskpad as a method of easing your administrative burden, not as a security measure.









Customized Features

You can create many extra and customized features and functions for your AD Taskpad using simple scripting. 
By writing a script (using batch shell or vbscript), and then adding it to your Taskpad, you can then start the script or apply the script to any workstation.  Below is an example of how to retrieve the last boot time from a workstation name in the Taskpad list.


Return Last Reboot

On Error Resume Next

Dim strUserIn

Dim goShell

Dim strComputerName

Dim WMIServices

Dim objUserSet

Dim oWshShell

Dim User

'Used to capture the AD Taskpad $NAME<0> argument

args = WScript.Arguments.Count
'Used to assign the the AD Taskpad argument to a variable

strUserIn = WScript.Arguments.Item(0) 

strComputer = strUserIn

ComputerName = strUserIn 

'Are you sure YES or NO routine

intAnswer = _

    Msgbox("Do you want to get Last Reboot on " & strComputer & " ?", vbYesNo, "Last Reboot")

If intAnswer = vbYes Then

' ------ EVENT LOG  ------

Set objNetwork = CreateObject("WScript.Network")

strUserName = objNetwork.UserName

strDescr = "Desktop: Last Reboot by " &  strUserName

Const EVENT_SUCCESS = 0

Const EVENT_ERROR = 1 

Const EVENT_WARNING = 3

Const EVENT_INFO = 4

set objWSHShell = Wscript.CreateObject("Wscript.Shell")

boolRC = objWSHShell.LogEvent(EVENT_INFO, strDescr, ComputerName)

' ------ END EVENT LOG ---------

Set objWMIService = GetObject("winmgmts:\\" _

& strComputer & "\root\cimv2")

Set colOperatingSystems = objWMIService.ExecQuery _

("Select * from Win32_OperatingSystem")

For Each objOS in colOperatingSystems

dtmBootup = objOS.LastBootUpTime

Exit For

Next

WMIDateStringToDate = CDate(Mid(dtmBootup, 5, 2) & "/" & _

Mid(dtmBootup, 7, 2) & "/" & Left(dtmBootup, 4) )

WMIDateStringToTime = CDate(Mid(dtmBootup, 9, 2) & ":" & _

Mid(dtmBootup, 11, 2) & ":" & Mid(dtmBootup,13, 2))

test = Msgbox(vbNewLine & "Last Boot Date= " & WMIDateStringToDate & vbNewLine & "Last Boot Time= " & "" & WMIDateStringToTime,, strComputer) 

'Msgbox(test)


''''''''''''''''''''''''''''''''''''''''''''logging – used for tracking usage'''''''''''''''''''''''''''''''''''''''''


Const ForAppending1 = 8

'This creates the object

Set objFSO = CreateObject("Scripting.FileSystemObject")

'This sets the LogFile

Set objLogFile1 = objFSO.OpenTextFile("\\ServerName\Logs\AD_LastReboot_Log.txt", ForAppending1, True)

'This writes to the test file

Set objNetwork = CreateObject("WScript.Network")

objLogFile1.WriteLine "Last Reboot" & "," & Date() & "," & Time() & "," & objNetwork.UserName & "," & ComputerName & "," & "Process" 

'This closes the input

objLogFile1.Close


Else

    Msgbox "Cancelled   ", 48, "Last Reboot"

''''''''''''''''''''''''''''''''''''''''''''logging – used for tracking usage'''''''''''''''''''''''''''''''''''''''''


Const ForAppending3 = 8

'This creates the object

Set objFSO = CreateObject("Scripting.FileSystemObject")

'This sets the LogFile

Set objLogFile3 = objFSO.OpenTextFile("\\ServerName\Logs\AD_LastReboot_Log.txt", ForAppending3, True)

'This writes to the test file

Set objNetwork = CreateObject("WScript.Network")

objLogFile3.WriteLine "Last Reboot" & "," & Date() & "," & Time() & "," & objNetwork.UserName & "," & ComputerName & "," & "Cancelled" 

'This closes the input

objLogFile3.Close


''''''''''''''''''''''''''''''''''''''''''''logging'''''''''''''''''''''''''''''''''''''''''

End If



































My example Taskpad

[image: image37.jpg]T Taskpad 1.0
Bl Window telp

€ 0 BB XEFIR R

Console Root\Active Directory Users and Computers i Console RoofVAcH

B3 Tech Links

W agmn share 5.

>

Change Caendr
&) Clesmup worstation 2

B curentuser

B Conputer
Hanagement

Q@ vent vewer
s

¢ Downtime Contacts

B Ep Cubertunk
Oucumentaion

[ —

F—

e
e + Copture Dacumertaton
B st Softusre + B e

Cap

&) ioternet kit
o Lastreboot s Cop

oventory status

i
a @) 1 Phone Lt

& Lo workstaton

69 [ responsbites

© Kooz

2 Lodiare Password

B vaver

O vt 10

© mappedomes o
& vz
@ MCinfo s Captre

LI

© ous + e

& Puers nstaled +
Cap

@ Restrt Pt Spocler
[ —

B netesmin
5 networknforsd

A

> ncal Clent Sevie:
O cncslvesiech
8 oncal 1T Docunert

B Remte Deseon

[——
Cintue

I Restart + PING

|~ e g i e e e e e e e e e e e e e e e e e e e e e e e e e 5 5

(@ ehore Dvectory
() ehone ecical sff
33 e Server

O —

£ software
e Documentation bd =

F 0t ) Tech Lnks

% Restart Workstation

GnEnGnGnGnGeGnGnGngnEngngnnn e

© Russ Explorer
@ RS Ineiret

o e e e e e e e e e i i e
0 el e o e o i e e i i e e i e e i i

ngngegegegegegegegegegegegegegegeqegeqegeqeqeqegeeeeeEeEEEEe

1 Ruas sConfia
@ s P sV

User Accounts B3 Disabled Accounts

: Pre-Widows 2000 .. Description 8 - s A
R Account Unlock g - £ Rt nccount & Disabled 2003 2_1
W iRecat Paswbrd € ExchanZe User (FULL) o by
§ Resetpassuod (manuel) € Exchange User % Disabled 2009_5_1
3 Oisabled 2005.7.7
4 Exchangs User & Disabled 2009_7_1
4 Exchangs User [ Disabled 2003_7_3
g g’;n‘v . [ Disabled 2009
€ ot e -3 D













PAGE  
41

8/29/2012                                                                                                        taskpad_master_document.doc                                                                                      Computer Systems Engineer

